aboutsummaryrefslogtreecommitdiff
path: root/tools/strelka-callSomatic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/strelka-callSomatic.nix')
-rw-r--r--tools/strelka-callSomatic.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/strelka-callSomatic.nix b/tools/strelka-callSomatic.nix
index 256065b..cf4b414 100644
--- a/tools/strelka-callSomatic.nix
+++ b/tools/strelka-callSomatic.nix
@@ -40,7 +40,18 @@ stage {
-m local \
-j $NIX_BUILD_CORES
- cp -r results $out
+ # Strelka writes runtime stats and timestamps;
+ # both have to be stripped to provide determinism
+ cd results/variants
+ rm *.tbi
+ for f in *.vcf.gz; do
+ gunzip $f
+ g=$(basename $f .gz)
+ sed -i '/^##fileDate/d' $g
+ sed -i '/^##startTime/d' $g
+ done
+ mkdir $out
+ cp -r * $out
'';
passthru.multicore = true;
}