aboutsummaryrefslogtreecommitdiff
path: root/tools/whisper-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2020-04-22 20:44:43 +1000
committerJustin Bedo <cu@cua0.org>2020-06-27 14:57:41 +1000
commit8a2778f8853ab687f83e07c4c322ab843b08f2af (patch)
tree76448ef65e5ac8c4d85fcc31e44de4269cb936ab /tools/whisper-index.nix
parent7611c8798f41427c5b48a3406d8bb9e0cde9786c (diff)
whisper: init 2.0
Diffstat (limited to 'tools/whisper-index.nix')
-rw-r--r--tools/whisper-index.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tools/whisper-index.nix b/tools/whisper-index.nix
new file mode 100644
index 0000000..675af7d
--- /dev/null
+++ b/tools/whisper-index.nix
@@ -0,0 +1,21 @@
+{ bionix
+, flags ? null
+}:
+
+ref:
+
+with bionix;
+with lib;
+with types;
+
+assert (matchFiletype "whisper-index" { fa = _: true; } ref);
+
+stage {
+ name = "whisper-index";
+ buildInputs = [ whisper.app ];
+ buildCommand = ''
+ ln -s ${ref} ref.fa
+ mkdir $out
+ whisper-index ${optionalString (flags != null) flags} index ref.fa $out $TMPDIR
+ '';
+}