aboutsummaryrefslogtreecommitdiff
path: root/tools/whisper-index.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/whisper-index.nix')
-rw-r--r--tools/whisper-index.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tools/whisper-index.nix b/tools/whisper-index.nix
new file mode 100644
index 0000000..675af7d
--- /dev/null
+++ b/tools/whisper-index.nix
@@ -0,0 +1,21 @@
+{ bionix
+, flags ? null
+}:
+
+ref:
+
+with bionix;
+with lib;
+with types;
+
+assert (matchFiletype "whisper-index" { fa = _: true; } ref);
+
+stage {
+ name = "whisper-index";
+ buildInputs = [ whisper.app ];
+ buildCommand = ''
+ ln -s ${ref} ref.fa
+ mkdir $out
+ whisper-index ${optionalString (flags != null) flags} index ref.fa $out $TMPDIR
+ '';
+}