aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-mem.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bwa-mem.nix')
-rw-r--r--tools/bwa-mem.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/tools/bwa-mem.nix b/tools/bwa-mem.nix
index 0d0f7d8..3208e48 100644
--- a/tools/bwa-mem.nix
+++ b/tools/bwa-mem.nix
@@ -29,8 +29,7 @@ in stdenv.mkDerivation {
done
cores=$(echo $NIX_BUILD_CORES ${optionalString bamOutput "- 1"} | bc)
if [[ $cores -lt 1 ]] ; then
- >&2 echo "not enough build cores"
- exit 1
+ cores=1
fi
bwa mem ${optionalString (flags != null) flags} -t $cores ref.fa ${fq input1} \
${optionalString (input2 != null) (fq input2)} \