aboutsummaryrefslogtreecommitdiff
path: root/tools/snpeff.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tools/snpeff.nix')
-rw-r--r--tools/snpeff.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/snpeff.nix b/tools/snpeff.nix
index c5ef04d..fb3f4a9 100644
--- a/tools/snpeff.nix
+++ b/tools/snpeff.nix
@@ -3,6 +3,13 @@
with bionix;
{
+ /* Annotate variants with SNPEff database. Some annotation DBs available in bionix.ref (e.g., bionix.ref.grch38.snpeff.db).
+ Type: { db, ... } -> vcf -> vcf
+ */
annotate = callBionixE ./snpeff-annotate.nix;
+
+ /* Annotate variants with dbNSFP database. Some dbNSFP annotation DBs available in bionix.ref (e.g., bionix.ref.grch38.snpeff.dbNSFP).
+ Type: { dbnsfp, ... } -> vcf -> vcf
+ */
dbnsfp = callBionixE ./snpeff-dbnsfp.nix;
}