summaryrefslogtreecommitdiff
path: root/haskell.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2023-02-07 17:09:26 +1100
committerJustin Bedo <cu@cua0.org>2023-02-08 10:46:05 +1100
commitd55277694dc2e8317dd4c0ea990a2e2bf41f6d4d (patch)
tree02219e04a8793b42233488d97c22a393a7532ab7 /haskell.nix
parentb555b36b5c14f7a4342b10bcea8374bfe5e0fac8 (diff)
haskell bindings
Diffstat (limited to 'haskell.nix')
-rw-r--r--haskell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/haskell.nix b/haskell.nix
new file mode 100644
index 0000000..56f10d4
--- /dev/null
+++ b/haskell.nix
@@ -0,0 +1,16 @@
+{
+ mkDerivation,
+ base,
+ inline-c,
+ vector,
+ hmatrix,
+ lib,
+}:
+mkDerivation {
+ pname = "coda-pca";
+ version = "0.1";
+ src = ./.;
+ libraryHaskellDepends = [base inline-c vector hmatrix];
+ description = "PCA on CODA";
+ license = lib.licenses.mit;
+}