summaryrefslogtreecommitdiff
path: root/haskell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'haskell.nix')
-rw-r--r--haskell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/haskell.nix b/haskell.nix
new file mode 100644
index 0000000..56f10d4
--- /dev/null
+++ b/haskell.nix
@@ -0,0 +1,16 @@
+{
+ mkDerivation,
+ base,
+ inline-c,
+ vector,
+ hmatrix,
+ lib,
+}:
+mkDerivation {
+ pname = "coda-pca";
+ version = "0.1";
+ src = ./.;
+ libraryHaskellDepends = [base inline-c vector hmatrix];
+ description = "PCA on CODA";
+ license = lib.licenses.mit;
+}