aboutsummaryrefslogtreecommitdiff
path: root/tools/bwa-index.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
committerJustin Bedo <cu@cua0.org>2019-01-09 16:38:42 +1100
commitc3babc9eb65dc8c56d07ce8a6ee0d8c03bbd223e (patch)
treef7d88ec21635664781c7c79fe0ea6f962ae38004 /tools/bwa-index.nix
parent9fd618d0305d4927c8d86fc37238d1216e401967 (diff)
large refactor
- use bionix.pkgs instead of nixpkgs - replace stdenv.mkDerivation with stage
Diffstat (limited to 'tools/bwa-index.nix')
-rw-r--r--tools/bwa-index.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/tools/bwa-index.nix b/tools/bwa-index.nix
index c879bc4..17b651f 100644
--- a/tools/bwa-index.nix
+++ b/tools/bwa-index.nix
@@ -1,19 +1,18 @@
{ bionix
-, nixpkgs
, flags ? null
}:
ref:
-with nixpkgs;
+with bionix;
with lib;
-with bionix.types;
+with types;
assert (matchFiletype "bwa-index" { fa = _: true; } ref);
-stdenv.mkDerivation {
+stage {
name = "bwa-index";
- buildInputs = [ bwa ];
+ buildInputs = with pkgs; [ bwa ];
buildCommand = ''
ln -s ${ref} ref.fa
bwa index ${optionalString (flags != null) flags} ref.fa