aboutsummaryrefslogtreecommitdiff
path: root/tools/fastp-run.nix
diff options
context:
space:
mode:
authorJustin Bedo <cu@cua0.org>2019-05-09 13:42:29 +1000
committerJustin Bedo <cu@cua0.org>2019-05-09 13:42:29 +1000
commit8f4b321c07f13ebe8597d1ab4ef3c6bda16f38af (patch)
tree300c68b1fec139221190b3643a560da4bbc82819 /tools/fastp-run.nix
parente1bb4233c72b0af954ec560759c408d92b2cea15 (diff)
fastp: rename run to check for consistency with fastqc
Diffstat (limited to 'tools/fastp-run.nix')
-rw-r--r--tools/fastp-run.nix40
1 files changed, 0 insertions, 40 deletions
diff --git a/tools/fastp-run.nix b/tools/fastp-run.nix
deleted file mode 100644
index c7cbb3c..0000000
--- a/tools/fastp-run.nix
+++ /dev/null
@@ -1,40 +0,0 @@
-{ bionix
-, flags ? null
-} :
-
-{ input1
-, input2 ? null
-} :
-
-with bionix;
-with pkgs.lib;
-
-# Match input file type—how to do .fq and .fq.gz? Does bz2 work?
-
-stage {
- name = "fastp";
- buildInputs = [ fastp.app ];
- outputs = [ "out" "fastq1" "fastq2" "html" "json" ];
- buildCommand = ''
- mkdir -p $out
- fastp \
- ${optionalString (flags != null) flags} \
- -i ${input1} \
- -o fastq1.fq.gz \
- ${optionalString (input2 != null) ''
- -I ${input2} \
- -O fastq2.fq.gz \
-
- cp fastq2.fq.gz $fastq2
- ln -s $fastq2 $out/fastq2.fq.gz
- ''}
-
- cp fastq1.fq.gz $fastq1
- cp fastp.html $html
- cp fastp.json $json
-
- ln -s $fastq1 $out/fastq1.fq.gz
- ln -s $html $out/fastp.html
- ln -s $json $out/fastp.json
- '';
-} \ No newline at end of file